A python package for ODE model analysis, parameter estimation and model discrimination

Latest version: 0.9.95

Detailed installation instructions and tutorial can now be found in the documentation.

Python and “Scientific” Python

S-timator is a (pure) Python package that can be installed from the Python Package Index with pip:

$ pip install stimator

However, S-timator relies heavily on the “Scientific Python ecossystem”, a set of Python libraries that brings high-performance scientific computing to the Python programming language.

In practical terms, this means that the installation of a standard Python distribution will not be enough to use S-timator. Instead, either the mandatory dependencies are installed one by one, or, more conveniently, Python is installed through a “scientific distribution”.

One of the following “scientific python” distributions is recommended, as they all provide an easy installation of all requirements:


S-timator supports Python versions 2.7 and 3.3+.

S-timator depends on a “scientific python stack”. The mandatory requirements for S-timator are the following libraries:

  • Python (2.7 or 3.3+)
  • numpy
  • scipy
  • matplotlib
  • pip
  • pandas
  • seaborn

The installation of these Python libraries is optional, but strongly recommended:

  • sympy: necessary to compute dynamic sensitivities, error estimates of parameters and other symbolic computations.
  • Jupyter and all its dependencies: some S-timator examples are provided as Jupyter notebooks.

The Anaconda Python Distribution, from “Continuum Analytics” is, arguably, the most convenient distribution. The full installation will provide all S-timator requirements.

From the same company, the Miniconda “slim” distribution is also an alternative, for those that worry about disk space. In this case, the necessary conda install‘s must be run for the dependencies, after installing Python.